Author Topic: probleme la partie audio de Varranger ne fonctionne plus  (Read 2349 times)

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
probleme la partie audio de Varranger ne fonctionne plus
« on: March 12, 2017, 09:11:07 AM »
Bonjour

Varranger a fait un gros plantage en pleine action ( je joins des copies d'écran)
Je jouais avec un clavier branché en midi sur la komplete audio , avec le synthé Vasynth et la banque additionnelle tyros (mon utilisation classique en fait)
je me suis retrouvé soudainement avec plus aucun son
j'ai eu un message comme quoi une erreur avait été provoquée par un composant externe (varranger ne dit pas son nom, sympa de sa part mais s'il avait bien voulu le dénonver ca nous aurait peut etre aidé ... :))
dans les reglages de port , je me suis apercu que toute la partie audio avait disparu (il tournait sur le moteur audio de la komplete)
j'ai essayé de relancer varranger mais il restait bloqué sur l'écran noir de démarrage
j'ai débranché la carte son et varranger s'est relancé , avec un message du style "erreur init 5 3" je ne me souviens plus exactement du contenu
Seulement je n'avais plus de son , la partie midi fonctionnait bien par contre (en entrée & sortie )
J'ai essayé de relancer mais il restait de nouveau figé sur l'écran de démarrage
Il s'en est suivi une longue séquence de démarrage / bidouillage où des fois il démarrait sans audio , des fois il restait bloqué au démarrage
Quand il démarrait sans audio , il m'a été possible de selectionner les différents drivers audio de la liste apres coup (bouton de réglage des ports) mais le logiciel se gelait par la suite
J'ai essayé de reinstallé le vasynth, je ne crois pas si ca a changé quelquechose ...
Bref , là actuellement , varranger ne marche plus en audio

Je précise que l'audio fonctionne apparemment tres bien avec d'autres applications (que ca soit la carte son interne ou la komplete)

Quelle serait la procedure pour refaire une "install clean" de varranger?
Est ce qu'il inscrit des choses dans la barre de registres au autres , qui pourraient être réinitialiser ?
Je n'ai rien vu de special dans le fichier ini , est ce qu'il y a des autres fichiers qui pourraient être modifier pour pallier à ce soucis ?

Peut etre que mes essais de vst ont mis le bazar quelquepart (j'ai bien scruté la liste des processus pour voir si une application ne monopolisait pas l'audio mais je n'ai rien vu de special) ?
Je precise que je tourne sous windows 10 , et il me semble que la stabilité est moins évidente que sur windows 7 (j'ai un vieux ordi sous windows7 , mais il est limite en config pour faire tourner le soft, il y a un peu de latence) .

Olivier

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #1 on: March 12, 2017, 02:44:31 PM »
Cela ressemble à une déconnexion de la carte son. Est ce que le cable USB n'a pas été tiré?
As tu téléchargé et installé les derniers drivers ASIO pour la NI Komplete audio
Parfois sur batterie, ou en mode économie d’énergie, Windows peut décider de limiter l'alimentation des ports USB.
C'est pour cela que sur scène il faut utiliser les modes PERFORMANCES ÉLEVÉES et ne pas faire fonctionner l'ordinateur sur batterie uniquement
Sinon, cela pourrait être un VST qui a planté, etc...

Pour repartir à 0, il faut couper les 2 processus vArranger2 et vASynth dans le gestionnaire de taches.

Si cela ne suffit pas, redémarrer l'ordi

Sinon, vérifier les connexion, cables, hub/ports USB et les drivers, en particulier de la carte son dans ton cas...

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #2 on: March 13, 2017, 07:59:36 AM »
j'avais bien redémarré l'ordi (meme éteint et rallumé) mais depuis j'ai ce fonctionnement chaotique avec la partie audio.
Je pense globalement que c'est encore un probleme avec la komplete mais j'ai les derniers drivers à ma connaissance et je n'ai pas de soucis particulier avec d'autres programmes
j'ai bien configuré le pc pour desactiver toutes les mises en veille / economie d'energie et compagnie donc je ne pense pas que le soucis vienne de là
 
Un truc que j'ai pas fait c'est de reinstaller la carte son , faudra que j'essaie
Et faire du menage dans les process windows , je pense pas que ca change quelquechose mais ca fera l'occasion ...

Est ce que d'autres utilisateurs de varranger utilisent la komplete audio ?
Est ce qu'ils ont eu des fonctionnements particuliers ?

olivier

Offline Lylo

  • vArranger
  • Hero Member
  • ***
  • Posts: 3788
  • Gender: Male
  • moderationforum.blogspot.fr
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #3 on: March 13, 2017, 12:23:14 PM »
Essai avec une latence de la carte plus importante peut-être.

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #4 on: March 19, 2017, 08:36:34 AM »
Bonjour

Apres une longue période de galere , j'arrive de nouveau à utiliser ma carte son Komplete avec varranger
Le probleme c'est que je ne sais pas bien comment a été résolu le soucis.
C'est reparti apres une mise à jour de windows et apres avoir un peu bricolé au niveau du systeme ...

Si ca se reproduit ou si ca arrive à un autre utilisateur de varranger, je ne serai pas capable de dire comment solutionner le probleme ...

Il reste quand meme un détail à régler , c'est que le son est "saturé" juste apres le lancement de varranger. Sans doute encore un reglage à faire dans la carte son , ou juste qu'il faut attendre que ca s'initialise correctement.


En tout cas , il y a quand meme une sacrée différence entre le son sortant de la komplete et celui de la carte son interne de l'ordi  (ca depends de l'ordi evidemment)

Olivier

Offline Tidom

  • vArranger
  • Hero Member
  • ***
  • Posts: 1258
  • Gender: Male
  • "Tant qu'on fait ça on traine pas au café" :)
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #5 on: March 19, 2017, 10:08:14 AM »
Si je peux me permettre !
J'ai toujours le petit EeePC ASUS Tm91 ( RAM 2Go )  de mes débuts sur vArranger.
Il n'est vraiment pas puissant. Tout juste suffisant pour jouer du SD2 mais très chagrin quant à l'alimentation des ports USB
Concernant ces ports USB par exemple je ne peux pas connecter 2 peripheriques sur un hub.
Ainsi il est impératif de connecter l'interfface Edirol UM-2G sur une prise USB et le Korg NanoKontrol sur l'autre prise USB.

Par contre sur mes LENOVO Intel I7 ou I5 mes 4 connections USB sont connectées ensemble sur un même port HUB USB:
1 -Carte son Edirol M16-DX
2- Convertisseur Midi USB  Edirol UM-2G
3- Korg Nanokontroller
4- Pedalier KETRON FS13.
et ça roule !
:)


Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #6 on: March 19, 2017, 03:32:39 PM »
Super. J'ai cru entendre des difficultés chez d'autres personnes avec des cartes NI Komplete
Parfois, la désinstallation complete puis réinstallation du dernier driver ASIO corrige le PB
Je crois qu'il y a des options de buffer, fréquence etc... dans l'appli NI

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #7 on: March 20, 2017, 11:56:51 AM »
j'aimerais bien avoir un retour d'experience d'autres utilisateurs de la NI komplete
Il doit encore y avoir des reglages à faire mais je vais y aller doucement.

Je sais pas si c'est lié , mais j'ai encore eu un soucis en jouant un morceau : en plein milieu , varranger s'est figé et les notes sont restées . Au bout d'une dizaine de secondes , le son s'est arreté et varranger m'a redonné la main. J'ai alors appuyé sur stop , puis start et c'est reparti ("stop" car varranger s'était arreté mais le bouton start/stop était resté sur "stop" )
contexte :
- windows 10
- midi in : cable midi/USB
- midi out 1 : vasynth (avec la banque tyros4 / gm2)
- audio : ASIO komplete 6 (Faut il choisir un autre driver ?)
- style : c'était un style original TYROS 1 (party)
- arrivé en jouant, sans toucher aucun bouton , et sans effectuer aucun changement de section ( A B C D Fill, ...)


C'est pas encore ca au niveau stabilité ...
« Last Edit: March 20, 2017, 12:10:35 PM by olivier71500 »

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #8 on: March 20, 2017, 12:35:51 PM »
@tidom : je ne sais pas comment est alimentée ta Carte son Edirol M16-DX , mais la komplete est autoalimentée par usb.

C'est pratique , mais je me posais la questions si ce n'était pas préjudiciable à la stabilité , car si les peripheriques pompent trop ca doit bien à un moment donné avoir un impact non ?
je me souviens aussi dans un passé pas si lointain , qu'il fallait débrancher des périphériques usb pour que d'autres fonctionnent ....
En tout cas, la carte son je ne la met pas sur un hub , elle est en direct sur le pc

olivier

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #9 on: March 20, 2017, 12:56:12 PM »
Quel est ton câble midi/USB?
Utilisais tu le song chords out chord loop quand c'est arrivé ?

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #10 on: March 20, 2017, 01:35:29 PM »
c'était un cable midi usb comme ca :
https://www.thomann.de/fr/maudio_midisport_uno.htm?glp=1&gclid=CI_IkuKY5dICFcE_GwodpRUFNQ


je n'utilisais pas le song chord ( "l'arrangeur" était en route , le style tournait depuis plusieurs minutes et donc je jouais l'accord main gauche et la melodie main droite, j'avais plusieurs sons sur la main droite (Right 1&2&3)  et 1 seul main gauche)

Offline Lylo

  • vArranger
  • Hero Member
  • ***
  • Posts: 3788
  • Gender: Male
  • moderationforum.blogspot.fr
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #11 on: March 20, 2017, 01:56:46 PM »
Sur un de mes pc portable j'ai eu la désagréable découverte de voir que mes ports usb étaient détectés par une carte son (Prodipe) comme issu d'un hub, c'est à dire que mes trois port usb n'en son qu'un en fait, tu peux en effet penser qu'il y a un soucis de ce côté.
Est-ce bien un pc portable ? Si oui que donne ton pc avec Asio4all http://asio4all.com sur ta carte son interne ?
Tu peux aussi essayer la carte NI avec Asio4all, certaines cartes "pro" fonctionnent mieux avec ça qu'avec leur drivers natifs.

Offline claudio

  • vArranger
  • Sr. Member
  • ***
  • Posts: 289
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #12 on: March 20, 2017, 03:19:17 PM »
Tous vos problèmes audio cités peuvent être liés aussi  par un manque de mémoire (Ram) :)

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #13 on: March 20, 2017, 03:27:07 PM »
Tu peux essayer également le driver WASAPI mais je ne conseille pas trop ASIO4ALL pour les cartes PRO

Offline claudio

  • vArranger
  • Sr. Member
  • ***
  • Posts: 289
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #14 on: March 20, 2017, 03:47:44 PM »
Comment régler correctement sa carte son sur un PC Windows?

Sujet à lire chez Native-instruments.com

- Ne choisissez pas WASAPI, DirectSound ou MME, qui ne fonctionneront pas de façon optimale avec la plupart des cartes son -

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #15 on: March 20, 2017, 04:20:32 PM »
As tu installé les derniers driver de la MAUDIO UNO?
Les anciens ne fonctionnaient pas très bien

Offline Tidom

  • vArranger
  • Hero Member
  • ***
  • Posts: 1258
  • Gender: Male
  • "Tant qu'on fait ça on traine pas au café" :)
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #16 on: March 20, 2017, 04:46:56 PM »
Olivier 71etc.
Pour te répondre ma carte  Edirol M16-DX a sa propre alimentation (220v => transfo ).
Bah ! Moi je pense qu'il ne faut pas trop demander à l'ordinateur.
C'est déjà un miracle qu'on bénéficie d'un arrangeur virtuel et maintenant de Soundfonts SF2 en interne.
J'y reviens mais à mon avis disposer de:
- un processeur suffisamment puissant.
-  de 8Go de RAM
-  de SSD rapide
-  d'alimentation externe de la carte son si possible.   
-  d'une interface Midi/USB reconnue efficace comme celles de la série Edirol:    UM-1G UM-2G   UM-3G
Avec le temps sont autant d'arguments favorisant la stabilité.


 

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #17 on: March 21, 2017, 07:26:16 AM »
Bon là concretement je suis parti en deplacement sans ordi , je vais voir en fin de semaine

pour les infos :
Native Instruments préconisent effectivement les drivers asio , et deconseillent  WASAPI, DirectSound ou MME (comme le précise Claudio)

la carte MAUDIO UNO : je l'utilise justement suite aux soucis avec la carte komplete qui a aussi des ports midi  (j'avais des notes qui restaient "coincées" avec le midi de la komplete dans varranger , je ne voulais pas cumuler les difficultés)

asio4all sur carte interne : semble plus stable , mais j'ai deja eu des notes "mangées" mais comme c 'est en jouant et que ca se passe vite , c'est pas facile à analyser

ordi / ram :
ca tourne sur un core I5 / 8Go Ram + SSD

Globalement,
est ce qu'il n'y a pas possibilité d'avoir des logs sur fichiers ? Sans log du logiciel , je crains qu'on tourne autour du pot pendant un moment ...
(j'admets que ca garantie pas d'avoir plus d'infos si le soucis est externe à varranger , mais ca pourrait mettre sur la piste non ? )
« Last Edit: March 21, 2017, 07:34:42 AM by olivier71500 »

Offline Tidom

  • vArranger
  • Hero Member
  • ***
  • Posts: 1258
  • Gender: Male
  • "Tant qu'on fait ça on traine pas au café" :)
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #18 on: March 21, 2017, 08:04:20 AM »
Quote
est ce qu'il n'y a pas possibilité d'avoir des logs sur fichiers ?

C'est quoi des logs sur fichier ?

Offline claudio

  • vArranger
  • Sr. Member
  • ***
  • Posts: 289
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #19 on: March 21, 2017, 08:25:46 AM »
Ce sont des fichiers regroupant l'ensemble des événements survenus sur un logiciel, une application, un serveur ou tout autre système informatique.

Un log se présente sous la forme d'un fichier texte classique, reprenant de façon chronologique, l'ensemble des événements qui ont affecté un système informatique et l'ensemble des actions qui ont résulté de ces événements.  :)

Offline Tidom

  • vArranger
  • Hero Member
  • ***
  • Posts: 1258
  • Gender: Male
  • "Tant qu'on fait ça on traine pas au café" :)
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #20 on: March 21, 2017, 08:29:53 AM »
Ah bon  !
Je suis informaticien sur le tas !
Toujours curieux d'apprendre comment peut-on récolter ces logs et les transmettre à Olivier qui semble apparemment en avoir besoin !  :) 

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #21 on: March 21, 2017, 11:40:33 AM »
@tidom : c'est pas exactement cela

Varranger tourne en cohabitation avec d'autres programmes windows, il doit "s'adapter" à des environnements différents ce qui n'est pas simple car chacun d'entre nous avons une configuration différente.
Par conséquent, c'est vraiment pas facile à mon avis de bien cerner d'où proviennent les soucis éventuels
Et comme quand on joue on est "captivé" par la musique et donc on est pas très attentifs aux évenements informatiques , je me disais que si varranger traçait les évènements / états mémoire et autres  ...  ça serait plus simple ensuite de récupérer ce fichier et de l'envoyer à Dan ... plutot que d'essayer de lui expliquer tant bien que mal (peut être plutôt mal que bien d'ailleurs) ce qu'on a rencontré ...
Et si ca se trouve , ces logs existent deja sans qu'on le sache ?

Mais là sur ce point, seul Dan sait vraiment ce qui est opportun , vu qu'il a le nez dans le code , et surtout qu'il est nettement plus compétent que nous pour l’interpréter 




Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #22 on: March 21, 2017, 02:28:11 PM »
On peut faire des logs pour débuger, mais d'abord, il faut savoir ce qu'on recherche :)

Ne pas écouter NI et on perd rien d'essayer quand même WASAPI au cas où ASIO pose problème :) Au niveau qualité sonore et latence, ça devrait être aussi bon, contrairement à ASIO4ALL.

Quel est ton instrument MIDI de base?

Après, en cas de problème, il y a aussi un outil interessant : http://www.thesycon.de/eng/latency_check.shtml

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #23 on: March 26, 2017, 05:47:00 AM »
Je n'ai pas eu le temps de faire beaucoup d'essais, mais dernierement ca fonctionnait bien.
J'ai remis le midi sur la komplete, histoire de liberer un port usb (je suis toujours assez interrogatif sur la capacité du portable à gérer convenablement un grand nombre de peripheriques usb)

au niveau des drivers : sur le driver asio komplete fonctionne correctement.
avec le driver wasapi , le son est hyper -saturé avec un effet un peu "flanger".

L'instrument midi de base est mon bon vieux kawai k5000s, toujours d'attaque malgré son age

latency_check : il est sympa ce petit outil. d'apres les bargraphes, je tourne a 1000-1500 us , et j'ai des pics tres ponctuels à plus de 2000

Je suis pas encore rassuré sur la stabilité de mon système ,  affaire à suivre

olivier

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #24 on: March 26, 2017, 05:50:13 AM »
Est ce que le message "Error n°6 in CT1() , l'opération arithmétique a provoqué un dépassement de capacité " peut avoir une relation de pres ou de loin avec ce genre d'incident ?

Il me semble qu'il m'affiche parfois ce message sans incidence sur le fonctionnement mais je préfere demander



Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #25 on: March 27, 2017, 12:30:57 AM »
Content que tes problèmes semblent résolus
Je ne sais pas si ton erreur dans CT1 cause un blocage du son. Il faudrait que tu découvres dans quelle circonstance cela apparait (changement de style, changement de variation...)
Je pense que les derniers drivers de la KOMPLETE doivent être meilleurs
Essaye le dpclat en coupant le wifi et bluetooth

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #26 on: March 27, 2017, 03:16:44 PM »

Dans le but de mieux identifier la source du probleme :
Est ce que "l'exception provoquée par un composant externe" est catchée par varranger ou ca remonte de plus haut (framework windows?)
On aurait moyen de tracer quelquechose ?

olivier

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #27 on: March 27, 2017, 04:02:11 PM »
Le compostant externe, c'est en général un VST ou bien le driver ASIO

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #28 on: March 28, 2017, 06:04:34 AM »
considerant le fait que j'utilisais pas les vst au moment des crachs, il reste le driver asio ....

Si jamais il s'avere qu'apres tous mes essais je n'arrive pas à obtenir un varranger stable avec NI ,  quelles cartes sons seraient préconisées pour tourner avec le logiciel ?

olivier

Offline Lylo

  • vArranger
  • Hero Member
  • ***
  • Posts: 3788
  • Gender: Male
  • moderationforum.blogspot.fr
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #29 on: March 28, 2017, 07:54:36 AM »
C'est plus une question matériel que logiciel dans le sens où si n'importe quel daw fonctionne avec une carte son, vArranger en fera de même. Pour ce qui me concerne j'ai fait tourner vArranger avec une Prodipe 12, une Echo Indigo Xpress, une Audiobox Presonus, un Sonic Cell, une FA101, un UMA25S Behringer, la carte son interne du pc... le seul soucis rencontré étant de devoir laisser 512 samples de buffer sinon pas de problème particulier.
Pour info sur mon pc de bureau j'ai des soucis pour faire fonctionner proprement ma Motu 828 firewire récemment acquise, quand il y a des conflit de chipset ou de drivers on est obligé de mettre les main dans le cambouis, malheureusement sur un portable la marge de manœuvre est mince.

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #30 on: March 28, 2017, 03:43:43 PM »
Je n'ai jamais eu de problemes avec la  komplete autrement qu'avec varranger .
Seulement, j'ai vu sur des forums internet (en anglais) que certains utilisateurs avaient rencontré des soucis avec cette carte son qui présentent quelques similitudes avec les miens .
(Je n'ai en revanche pas trouvé d'infos sur le forum varranger)
Je vais continuer à me documenter  , et à tester car j'ai pas très confiance au systeme (ca risque de planter au mauvais moment... )
Est ce que l'on ressent une différence importante dans la qualité du son suivant les cartes sons audio ?
Entre la komplete et la carte son interne de mon PC c'est vraiment très net , mais la carte son interne est vraiment "light" . Je suppose que la différence est moins marquée entre appareils de meme gamme ..

olivier

Offline FONTAINE

  • vArranger
  • Newbie
  • ***
  • Posts: 19
    • View Profile
Rotary uvi
« Reply #31 on: April 01, 2017, 12:05:54 PM »
Bonjour
comment utiliser Rotary UVI sur vArranger si quelqu'un
peux m'aider

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #32 on: April 09, 2017, 12:41:08 PM »
Bonjour

Je n'ai pas eu de problemes particuliers depuis avec la partie audio.
Affaire à suivre , car je n'ai pas encore bien compris la cause du probleme ni la solution ....


Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #33 on: December 01, 2017, 02:17:30 PM »
Olivier, qu'en est t'il de ta Komplete Audio 6 ?
J'ai un utilisateur qui me dit que ça plante au premier démarrage? Sauf s'il la débranche / rebranche ?
La MIDI OUT de la Komplète audio ne fonctionne plus si le usb buffer est reglé à 1ms

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #34 on: December 01, 2017, 04:09:51 PM »
La komplete audio fonctionne pas trop mal maintenant, mais faut admettre qu'avec varranger il m'arrive de devoir booter plusieurs fois Va (c'est assez rare desormais )
Jamais trop eu de problemes avec les autres outils MAO (hotes VST , kontakt, ....). Ca provient peut etre de la gestion des ressources audio (est ce que varranger demande un acces exclusif alors que d'autres sont plus permissifs ?... )

Il y a plusieurs choses à faire tres attention :
- aucun programme ne doit utiliser la komplete au momen,t de lancer VA , sinon ca marche pas (windows a vite fait de l'assigner par défaut comme sortie audio)
et je pense qu'il est préférable qu'aucun programme ne l'utilise avant (peut etre qu'il y a des acces ressources qui sont parfois mal libérés ? avec windows ca me surprendrait pas)
- parmi les ports USB du PC , il y a des ports USB qui fonctionnent mieux que d'autres (ca doit etre en fonction de leur position, je pense qu'il y a une sorte de priorité sur l'utilisation des ports)
- et tres important : il faut aller regler les parametres de performances et desactiver tous les parametres d'économie d'energie , surtout ce qui concerne les ports
- il est préférable de ne pas la mettre sur un hub usb qui contient plusieurs autres peripheriques , sinon elle peut manquer d'energie (mais là ca se voit au fait que la led "USB" de la Komplete clignote)
- j'ai aussi essayé de virer tous les programmes qui servent à rien (pas tous car il y a des process dont je ne sais absolument pas à quoi ils servent mais j'ai peur de flinguer quelquechose dans l'OS)


Olivier
 

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #35 on: December 01, 2017, 04:11:44 PM »
Je regarderai pour l'usb buffer , je ne sais plus sur quoi je l'ai réglé

olivier

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #36 on: December 02, 2017, 09:12:50 AM »
voici les reglages de ma komplete
ca doit pas etre loin de ceux qui sont affectés par defaut

olivier

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7622
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #37 on: December 05, 2017, 06:58:42 PM »
Merci pour ces infos !

On a trouvé le problème!!

En fait, si la KOMPLETE AUDIO 6 n'est pas configurée en 44100Hz, le driver fait planter vArranger lorsque vArranger lui demande de se mettre en 44100Hz
Probablement un problème du driver NI
C'est pour ça que si Windows ou un autre logiciel utilise la carte son en 48000 Hz par exemple, alors ça va planter au lancement de vArranger



Pour info :
Pour ne pas avoir à redémarrer l'ordi en cas de plantage, il faut faire un clic droit sur la barre des taches, et lancer le Gestionnaire des tâches.
Menu Options, Toujours visible.
Ainsi en cas de problème, touche windows, clic droit, gestionnaire des taches... arrêter vArranger

Offline olivier71500

  • vArranger
  • Sr. Member
  • ***
  • Posts: 465
    • View Profile
Re: probleme la partie audio de Varranger ne fonctionne plus
« Reply #38 on: December 05, 2017, 07:47:04 PM »
J'avais effectivement lu sur des forums que NI préconisait d'utiliser exactement les memes reglages pour les applis .

J'ai toujours pas réussi à l'utiliser correctement en mode multi client . Ca doit venir de ca . il doit y avoir des reglages qui diffèrent. Faudra que je regarde cela de plus pres.


Autre chose au passage : seul le driver ASIO de la Komplete (sur le site NI) m'a vraiment donné satisfaction. Les autres drivers occasionnent des problemes de son (parfois saturé , ou problemes de saccadement, ... )

olivier