Author Topic: Delay (latency) with Yamaha Montage 6 !  (Read 449 times)

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Delay (latency) with Yamaha Montage 6 !
« on: December 04, 2018, 03:54:39 PM »
Hello!
I have the following problem:
I have a delay (latency) when switching to a different style (rhythm):
With vArranger2 and Ketron SD1000 I have no problem, but with Yamaha Montage 6 (also with Motif XF6) always comes a small delay (GM / multi-mode).
If I only want to change one sound, for example For example, a drum kit (Part 10), everything is fine, but a style changes in eight sounds at a time, and then comes a delay?
Can someone help me?

Best Regards

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #1 on: December 04, 2018, 04:07:57 PM »
What vArranger version do you use?
Do you see a difference if you select GM2 or XG mode?

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #2 on: December 04, 2018, 04:42:03 PM »
Hi Dan!
Version is new 1.19.01 and does not matter is the GM, GM2 or XG mode.

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #3 on: December 04, 2018, 04:54:38 PM »
Maybe you select some sounds that change many DSP inside the Montage and take some time ?
What about if you change the style on variation A, where not so much program changes are sent
Do you use the USB port of the Montage for MIDI, and not the MIDI port?

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #4 on: December 04, 2018, 07:16:54 PM »
I have switched off all DSP in the assembly.
No matter which style on variant A, B, C, D.
Midi is mounting via USB port.
Problem is  in Montage not in vArranger2. Same is with Motif XS.
A kolege has Korg PA4 and Motif XS and has the same problems.
« Last Edit: December 04, 2018, 07:19:30 PM by mdm »

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #5 on: December 04, 2018, 07:20:32 PM »
With the Korg pa? Or motif XS?

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #6 on: December 04, 2018, 07:21:40 PM »
Motif XS !!!

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #7 on: December 04, 2018, 07:30:22 PM »
I don't have any motif.
I will try on my Yamaha PSR
Not sure if it is the same
By the way it is just a little wait of few milliseconds between styles.
Not so much a problem, only if you want to chain 2 styles perfectly in the same song

Offline agaton

  • vArranger
  • Sr. Member
  • ***
  • Posts: 327
  • Gender: Male
  • trans audio
    • View Profile
    • Trans Audio
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #8 on: December 05, 2018, 09:16:31 PM »
Maybe, but only maybe, it is the problem with SysEx.
Try to filter SysEx on Yamaha Receive MIDI and check it.
Yamaha has its "specially rules" on MIDI Transmit and
Receive, it can be reason for this latency. This SysEx can
make MIDI Overflow on Yamahas.

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #9 on: December 05, 2018, 11:59:04 PM »
When you have some latency.
Can you take a picture of vArranger with the song 1 and with the song 2?
So we can see what are the program changes that cause the slowness

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #10 on: December 06, 2018, 10:06:08 AM »
Thank you very much Dan, Thank you Agaton (Zlatko)!

I have problems with every style and everything is the same, so picture does not bring anything
Each Style Part: Drum.Perc, Bass, ACC has MSB, LSB, PC and I have made par style with same MSB and LSB only changes PC but again comes problem.
I have already tried with filters SyxEx but does not help.
Only is ok if I do Two Style with same sounds per part (Same: Drum, Perc, Bass, Acc).

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #11 on: December 06, 2018, 10:41:03 AM »
Do you change right and left hand sounds too ?
What if you only change the acc1 sound ?

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #12 on: December 06, 2018, 03:44:30 PM »
No, I only use accompaniment tracks.
acc1 is mostly guitar and delay is also on drum track is better to hear.
I saved two styles where all the tracks are from only drum track playing and when changing from Style1 to Style2 changes programchange on the Montage(only 10) comes
but still late.
If I use Soundedit or INS just take a different sound (drum set) when playing a style, everything is fine.
So there is no possibility.
Nevertheless many thanks
« Last Edit: December 06, 2018, 03:47:40 PM by mdm »

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #13 on: December 06, 2018, 03:48:04 PM »
It is only late if you change the drum tracks? But it is OK if you change the 5 other tracks?

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #14 on: December 06, 2018, 03:59:52 PM »
No, every part is too late, but the drum part is the worst because BBD and HHC are always at 1.0.0 and usually louder than any other parts.
It is best to leave this topic as it is not without latency.
Many thanks!
« Last Edit: December 06, 2018, 04:03:02 PM by mdm »

Offline Dan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7618
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #15 on: December 06, 2018, 04:06:47 PM »
Yes but strange that if you change the drum kit outside the first downbeat, it is not stopping the music.
vArranger sends a lof of data for the drum kit, especially for the volumes reverb of each notes etc...
Not sure how montage understand the XG messages of the drumkits

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #16 on: December 06, 2018, 04:33:08 PM »
No idea?
Anyway, Yamaha Montage is a better synth for me and I'm very happy.
Many thanks

Offline agaton

  • vArranger
  • Sr. Member
  • ***
  • Posts: 327
  • Gender: Male
  • trans audio
    • View Profile
    • Trans Audio
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #17 on: December 08, 2018, 03:25:25 PM »
It is anyone "kosmetic" problem, it can be fixed very fast. Montage must change sounds so fast like it do that on commands from buttons on its command table. If you have Instrument Definition for Montage, copy it in vArranger folder, it will be helpfull for Bank and PCG on Montage This issue which make latency can be find.

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #18 on: December 09, 2018, 10:46:46 PM »

Thanks Zlatko,
but Montage INS is already in vArranger2 INS Folder.

Offline agaton

  • vArranger
  • Sr. Member
  • ***
  • Posts: 327
  • Gender: Male
  • trans audio
    • View Profile
    • Trans Audio
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #19 on: December 10, 2018, 02:44:51 AM »
Than you have to go to General  / Midi Setup, and check very carefully everyone
item. It is recommended that you try with conventional Midi cables to connect
Montage with your computer, cause it is not strange that USB to Midi driver is not
always the best choice. Yamaha is not the best producer of USB to Midi Interfaces.
Simply try to see the result. The first my suspicion is Midi connection or Midi processing
between Yamaha and comp.

Offline mdm

  • vArranger
  • Newbie
  • ***
  • Posts: 11
    • View Profile
Re: Delay (latency) with Yamaha Montage 6 !
« Reply #20 on: December 10, 2018, 06:01:12 PM »
I have problem with PC-Montage (USB Midi or Midi)
 Korg PA4-Montage (Midi), Tyros5-Montage (Midi).
This is not 100%